**Microchannel Cell**

This example was originally formulated by Albert Witarsa under Professor Bruce Finlayson’s supervision at the University of Washington in Seattle. It was part of a graduate course in which the assignment consisted of using mathematical modeling to evaluate the potential of patents in the field of microfluidics.

This model treats a so-called H-micro cell for separation through diffusion. The cell puts two different laminar streams in contact for a controlled period of time. The contact surface is well defined, and by controlling the flow rate it is possible to control the amount of species transported from one stream to the other through diffusion.

![Diagram of the H-micro cell](image)

**Model Definition**

The geometry of the microcell ([Figure 6-16](#)) is taken from Albert Witarsa’s and Professor Finlayson’s assignment. The cell geometry is divided in half due to symmetry. The design is done to avoid upsets in the flow field when the two streams, A and B, are united. The reason for this is to avoid the two streams mixing through convection, because this would mix all species equally and you would lose control over the separation abilities. The transport of species from streams A to B should take place only by diffusion, which implies that species with low diffusion coefficients stay in their respective streams.

![Model geometry](image)

*Figure 6-15: Diagram of the H-micro cell.*

*Figure 6-16: Model geometry. Due to symmetry, only half the cell must be modeled. The design is also required so as to smoothly let both streams come in contact with each other. This avoids any type of convective mixing.*
The first part of the problem involves the solution of the fluid flow in the H-cell. According to the specifications, the flow rate at the inlet is roughly 0.1 mm/s. This implies that the Reynolds number is low and well inside the region of laminar flow:

\[
Re = \frac{d \cdot \frac{du}{dx}}{\mu} = \frac{1 \cdot 10^{-7} \cdot 1 \cdot 10^{-4}}{1 \cdot 10^{-3}}
\]

Equation 6-23 gives a Reynolds number of 0.001 for a water solution and the channel dimensions given in Figure 6-16, and this value is typical for microchannels. Thus it is easy to get a numerical solution of the full momentum balance and continuity equations for incompressible flow with a reasonable number of elements. The equations that you must solve are the Navier-Stokes equations at steady-state:

\[
\begin{align*}
- \nabla \cdot (\eta (\nabla \mathbf{u} + (\nabla \mathbf{u})^T)) + \rho (\mathbf{u} \cdot \nabla) \mathbf{u} + \nabla p &= 0 \\
\nabla \cdot \mathbf{u} &= 0
\end{align*}
\]

where \( \rho \) denotes density (kg/m\(^3\)), \( \mathbf{u} \) is the velocity vector (m/s), \( \eta \) denotes viscosity (kg/m·s), and \( p \) equals pressure (Pa).

Separation in the H-cell involves species in a relatively low concentration compared to the solvent, in this case water. This means that the solute molecules interact only with water molecules, and it is safe to use Fick's law to describe the diffusive transport in the cell. The mass balance equation for a solute is present in the Convection-Diffusion application mode, which solves the equation

\[
\begin{align*}
- \nabla \cdot (D \nabla c + c \nabla \mathbf{u}) &= 0
\end{align*}
\]

In this equation, \( D \) denotes the diffusion coefficient (m\(^2\)/s) and \( c \) represents the concentration (mol/m\(^3\)). This model uses three different values of \( D \) in order to simulate the mixing of different species. The values of the diffusion coefficient are \( 1 \cdot 10^{-11} \), \( 5 \cdot 10^{-11} \) and \( 1 \cdot 10^{-10} \).

In the first approach, assume that a change in solute concentration does not influence the fluid's density and viscosity. This implies that it is possible to solve the Navier-Stokes equations first and then solve the mass balance equation. In order to solve these equations, you need some boundary conditions. A second step uses a quadratic dependence of the viscosity on concentration:

\[
\begin{align*}
\eta &= \eta_0 (1 + c^2)
\end{align*}
\]

The influence of concentration on viscosity is usually observed in solutions of larger molecules.

Start by looking at the boundary conditions for the Navier-Stokes equations, conditions that Figure 6-17 explains qualitatively.

The normal flow/pressure conditions and the inlets and outlets set the velocity at the boundary perpendicular to the boundary. This is expressed by
\[ \mathbf{u} \cdot \mathbf{t} = 0 \]
(6-27) \[ P = P_i \]

where \( p_i \) is the pressure. At the outlet, the pressure is set to zero, and at the inlet the pressure is given by the pressure drop over the cell. The inlet and outlet conditions comply with the H-cell being a part of a channel system of constant width, which allows for the assumption of developed flow, and that velocity components tangential to the outlet boundary are zero. The symmetry boundary condition means that the velocity component in the normal direction of the surface is zero:

(6-28) \[ \mathbf{u} \cdot \mathbf{n} = 0. \]

The no-slip conditions state that the velocity is zero in the \( x-, y- \) and \( z- \)directions at the wall:

(6-29) \[ (u, v, w) = (0, 0, 0) \quad \text{at the walls.} \]

The boundary conditions for the mass balance define the composition of the solution at the inlet:

(6-30) \[ c = c_A \quad \text{at inlet A} \]
\[ c = c_B \quad \text{at inlet B}. \]

The walls of the cell are modeled as insulating boundaries, which yields

(6-31) \[ (-D \nabla c + \mathbf{c} \cdot \mathbf{n}) \cdot \mathbf{n} = 0 \quad \text{at the walls.} \]

This equation states that the flux perpendicular to the boundary equals zero. The outlet condition is obtained assuming that the convective transport is much larger than the diffusive transport perpendicular to the outlet. This is given in the equation

(6-32) \[ (-D \nabla c + \mathbf{c} \cdot \mathbf{n}) \cdot \mathbf{n} = \mathbf{c} \cdot \mathbf{n} \quad \text{at the outlet} \]

which eliminates concentration gradients in the direction of flow at the position of the outlet.

**Results**

Figure 6-18 shows the velocity field, defined as the modulus of the velocity vector. The flow is symmetric and is not influenced by the concentration field.

![Figure 6-18: Modulus of the velocity vector.](image)

Figure 6-19 shows the concentration distribution for a species with a relatively large diffusivity, the light species in this study.
Figure 6-19: Concentration distribution for the species with the larger diffusivity.

The calculations show that the degree of mixing is almost perfect for the lighter species. The species with a diffusion coefficient that is ten times less than the lighter species shows a completely different result.

Figure 6-20: Concentration distribution for species with the smaller diffusivity.

The concentration distribution in Figure 6-20 indicates that the diffusion coefficient for the species is low enough to avoid any significant mixing between streams A and B. The simulation clearly shows that the H-cell can separate lighter molecules from heavier ones. A cascade of H-cells can achieve a very high degree of separation.

In some cases, especially those involving solutions of macro-molecules, the concentration of the macro-molecule has a large influence on the liquid’s viscosity. In such a case it is necessary to solve the Navier-Stokes and convection-diffusion equations simultaneously. Figure 6-21 shows the results of this simulation. You can see the flow field is largely influenced by changes in the concentration. It is clear from this plot that the velocity becomes asymmetric due to changes in viscosity.
Figure 6-21: Velocity field. The viscosity varies with the concentration according to $\eta = \eta_0 (1 + c^2)$. The figure shows that the velocity field is greatly affected by variations in concentration. Compare it to the velocity field in Figure 6-18.

**Model Library Path:** Chemical_Engineering_Module/Microfluidics/hcell

**Modeling Using the Graphical User Interface**

1. Start COMSOL Multiphysics.
2. On the **New** page set the **Space dimension** to **3D**
3. In the list of application modes select **Chemical Engineering Module>Momentum balance>Incompressible Navier-Stokes**.
4. Click the **Multiphysics** button, then click **Add**.
5. In the list of application modes select **Chemical Engineering Module>Mass balance>Convection and Diffusion**.
6. Click **OK**.

**OPTIONS AND SETTINGS**

1. Select **Constants** from the **Options** menu.
2. Enter the following variable names and expressions in the **Constants** dialog box; when done, click **OK**:

<table>
<thead>
<tr>
<th>NAME</th>
<th>EXPRESSION</th>
</tr>
</thead>
<tbody>
<tr>
<td>eta</td>
<td>1e-3</td>
</tr>
<tr>
<td>rho</td>
<td>1e3</td>
</tr>
<tr>
<td>p0</td>
<td>2</td>
</tr>
<tr>
<td>D</td>
<td>1e-11</td>
</tr>
<tr>
<td>c0</td>
<td>1</td>
</tr>
</tbody>
</table>

**GEOMETRY MODELING**

1. From the **Draw** menu select **Work Plane Settings**.
2. Use the default **Quick** work plane (the $x$-$y$ plane at $z = 0$) by clicking **OK**.
3. Open the **Axes/Grid settings** from the **Options** menu.
4. On the **Axis** page enter the following settings:

<table>
<thead>
<tr>
<th>PROPERTY</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>x min</td>
<td>-1</td>
</tr>
<tr>
<td>x max</td>
<td>15</td>
</tr>
<tr>
<td>y min</td>
<td>-7</td>
</tr>
<tr>
<td>y max</td>
<td>7</td>
</tr>
</tbody>
</table>

5. On the **Grid** page clear the **Auto** check box and set both the **x spacing** and **y spacing** to 1.

6. Click the **Line** button on the Draw toolbar, then click the points with the x- and y-coordinates at (0, 6) and (0, 2).

7. Select the **2nd Degree Bezier Curve** tool on the Draw toolbar and click at the coordinate pairs (0, 0) and (2, 0).

8. Select the **Line** tool and click at the coordinates (12, 0).

9. Select the **2nd Degree Bezier Curve** tool and click at the coordinates (14, 0) and (14, 2).

10. Select the **Line** tool and click at the coordinates (14, 6). Continue by clicking at the coordinates (13, 6) and (13, 2).

11. Select the **2nd Degree Bezier Curve** tool and click at the coordinates (13, 1) and (12, 1).

12. Select the **Line** tool and click at the coordinates (2, 1).

13. Select the **2nd Degree Bezier Curve** tool and click at the coordinates (1, 1) and (1, 2).

14. Select the **Line** tool and click at the coordinates (1, 6).

15. Click the right mouse button to close the set of lines and create a solid object.

You have now created half of the 2D cross section and can use copy, paste, and rotate operations to create the other half.

1. Click the **Copy** button and then the **Paste** button, both on the Main toolbar. Let the **Displacements** remain at 0 and click **OK**.

2. Click the **Rotate** button on the Draw toolbar and enter 180 in the **Rotation angle** edit field.

3. Set the point (7, 0) as the **Center point**. Click **OK**.

4. Choose **Select All** in the **Edit** menu.

5. Click the **Create Composite Object** button on the Draw toolbar.

6. Clear the **Keep interior boundaries** check box. Click **OK**.

The cross section is now finished and you can extrude it to the full 3D geometry.

7. Select **Extrude** from the **Draw** menu. Let the **Distance** remain 1. Click **OK**.

The last step is to scale the geometry to the correct scale.

8. Click the **Scale** button on the Draw toolbar.

9. Enter \(1\times10^{-5}\) in both **Scale factor** edit fields.

10. Click **OK**.

**PHYSICS SETTINGS**
Boundary Conditions

1. Select **Geom1: Incompressible Navier-Stokes (chns)** from the **Multiphysics** menu.
2. Select **Boundary Settings** from the **Physics** menu.
3. Specify boundary conditions as in the following table; when done, click **OK**:

<table>
<thead>
<tr>
<th>BOUNDARY</th>
<th>2, 8</th>
<th>20, 22</th>
<th>4</th>
<th>ALL OTHER</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type</td>
<td>Normal flow/Pressure</td>
<td>Normal flow/Pressure</td>
<td>Slip/ Symmetry</td>
<td>No-slip</td>
</tr>
<tr>
<td>p</td>
<td>p0</td>
<td>0</td>
<td>-</td>
<td>-</td>
</tr>
</tbody>
</table>

4. Select **Geom1: Convection and Diffusion (chcd)** from the **Multiphysics** menu.
5. Select **Boundary Settings** from the **Physics** menu.
6. Specify the boundary conditions in the following table; when done, click **OK**:

<table>
<thead>
<tr>
<th>BOUNDARY</th>
<th>2</th>
<th>8</th>
<th>20, 22</th>
<th>ALL OTHER</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type</td>
<td>Concentration</td>
<td>Concentration</td>
<td>Convective flux</td>
<td>Insulation/ symmetry</td>
</tr>
<tr>
<td>c0</td>
<td>-c0</td>
<td>0</td>
<td>-</td>
<td>-</td>
</tr>
</tbody>
</table>

Subdomain Settings

1. Select **Geom1: Incompressible Navier–Stokes (chns)** from the **Multiphysics** menu.
2. Select **Subdomain Settings** from the **Physics** menu.
3. Specify the subdomain settings in this table; when done, click **OK**:

<table>
<thead>
<tr>
<th>SUBDOMAIN</th>
<th>1</th>
</tr>
</thead>
<tbody>
<tr>
<td>p</td>
<td>rho</td>
</tr>
<tr>
<td>η</td>
<td>eta</td>
</tr>
<tr>
<td>Fx</td>
<td>0</td>
</tr>
<tr>
<td>Fy</td>
<td>0</td>
</tr>
</tbody>
</table>

4. Select **Geom1: Convection and Diffusion (chcd)** from the **Multiphysics** menu.
5. Select **Subdomain Settings** from the **Physics** menu.
6. Specify the subdomain settings given below; when done, click **OK**:

<table>
<thead>
<tr>
<th>SUBDOMAIN</th>
<th>1</th>
</tr>
</thead>
<tbody>
<tr>
<td>D isotropic</td>
<td>D</td>
</tr>
<tr>
<td>R</td>
<td>0</td>
</tr>
<tr>
<td>u</td>
<td>u</td>
</tr>
<tr>
<td>v</td>
<td>v</td>
</tr>
<tr>
<td>w</td>
<td>w</td>
</tr>
</tbody>
</table>

MESH GENERATION
COMPUTING THE SOLUTION

Start by first computing the solution for the velocity field and then use that solution for solving the mass transport problem.

1. Click the Solver Manager button on the Main toolbar.
2. On the Solve For page select Incompressible Navier-Stokes (chns).
3. Click the Initial value tab and click the Initial value expression option button.
4. Click OK.
5. Click the Solve button on the Main toolbar.

You have now computed the velocity field and can use that solution to make a parametric analysis for the mass transport problem with varying diffusivity.

1. Click the Solver Manager button on the Main toolbar.
2. On the Solve For page select Convection and Diffusion (chcd).
3. Click the Initial Value tab and then click the Current solution option button.
4. Click OK.
5. Open the Solver Parameters dialog box from the Solve menu. Select Parametric from the Solver list.
6. Enter $D$ in the Name of parameter edit field.
7. Edit $1e-10$ $5e-11$ $1e-11$ in the List of parameter values edit field.
8. Click OK.
9. Click the Solve button on the Main toolbar.

POSTPROCESSING AND VISUALIZATION

To create Figure 6-18 follow these steps:

1. Open the Plot Parameters dialog box from the Postprocessing menu.
2. Select the Slice check box on the General page.
3. Clear the Element refinement Auto check box and enter 5 in the corresponding edit field.
4. Click the Slice tab.
5. Set Slice data to Velocity field (chns) in the Predefined quantities list.
6. Under Slice positioning set $x$ levels to 5, $y$ levels to 2, and $z$ levels to 1.
7. Click OK.

To create Figure 6-19 follow these steps:

1. Open the Plot Parameters dialog box from the Postprocessing menu.
2. On the General page select $1e-10$ from the Parameter value list.
3. Go to the Slice page and select Concentration, $c$ from the Predefined quantities list.
4 Click OK.

Figure 6-20 is create the same way as Figure 6-19 except using the parameter value 1e-11.

PHYSICS SETTINGS—STUDY 2

1 Select 1 Incompressible Navier-Stokes (chns) from the Multiphysics menu.
2 Open the Subdomain Settings dialog box and change the viscosity expression from \( \eta \) to \( \eta(1+c^2) \).
3 Click OK.

COMPUTING THE SOLUTION—STUDY 2

When the viscosity is concentration dependent you must solve for all equations simultaneously.

1 Click the Solver Manager button on the Main toolbar.
2 In the Solve page select Geom1 (3D) from the Solve for variables list. Click OK.
3 Open the Solver Parameters dialog box from the Solve menu.
4 Select Stationary nonlinear from the Solver list. Click OK.
5 Click the Solve button on the Main toolbar.

POSTPROCESSING AND VISUALIZATION—STUDY 2

To create Figure 6-21, do exactly as for Figure 6-18.