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AC E l e c t r o k i n e t i c a l l y  Enhan c ed 
S u r f a c e  R e a c t i o n s

Introduction

This model studies the use of AC electrokinetic forces to enhance the rate of transport 
of reactants to a reaction surface on the wall of a microchannel. It was developed for 
the MEMS Module by Gaurav Soni, Marin Sigurdson, and Carl Meinhart of the 
Department of Mechanical and Environmental Engineering, University of California, 
Santa Barbara.

The modeled system mixes a small concentration of a biological analyte with the fluid 
in a microchannel where a reaction surface is located on the channel walls. The flow 
velocity perpendicular to the surface is so small that the analyte, which is supposed to 
bind to an antibody ligand on this surface, is transported mainly by diffusion. The rate 
of the binding reaction on the surface is usually large enough to bind practically all 
analyte molecules appearing there. Thus, the process is said to be transport limited and, 
in order to increase the reaction rate, the system must increase the transport of 
molecules to the reaction surface.

AC electrokinetic forces can generate swirling patterns in the fluid and thereby 
enhance the transport of the analyte to the reaction surface (Ref. 1). Biological 
immunoassays, which detect an analyte through their binding response to an antibody 
ligand, can use these flow patterns to great advantage.

The AC electrokinetic forces arise when the fluid absorbs energy from an applied 
nonuniform AC electric field by means of Joule heating. The temperature increase 
changes the fluid’s conductivity and permittivity. Consequently the fluid experiences 
an effective or time-averaged volume force, which depends on the conductivity and 
permittivity gradients and on the field intensity. By changing the shape of the electric 
field it is possible to alter the fluid-flow pattern so that required amounts of analyte 
molecules reach the reaction surface.

Model Definition

Figure 1 shows the model geometry, which consists of a section of the channel 40 μm 
high and 250 μm long. Two electrodes, each 60 μm wide, are located on the lower 
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boundary at distances of 50 μm and 130 μm from the inlet. The reaction surface, 
20 μm wide, is located on the top wall, 90 μm from the inlet.

The fluid flows from left to right. The incoming flow profile is characteristic for fully 
developed laminar flow, that is, it is parabolic with zero velocity at the channel walls. 
An applied electrothermal force creates swirling patterns in the flow at the channel’s 
center.

The two electrodes produce an AC electric field that heats the fluid and creates the 
electrothermal force. The model assumes that the electrodes are perfect heat 
conductors and remain at a constant ambient temperature. At the inlet and the outlet, 
the temperature gradually approaches the ambient. At all other boundaries the model 
assumes that the channel is thermally and electrically insulated.

The incoming flow has a small concentration of a biological analyte, which the reaction 
surface on the upper boundary transports and adsorbs. Any remaining concentration 
exits the channel with the fluid at the right boundary.

Having solved for the steady-state flow for a given electric field and the resulting 
electrothermal force, this example reviews a transient simulation of the material 
balance of the analyte, assuming that the initial concentration in the channel is zero 
and that a given concentration of the analyte is injected at the inlet at time zero.

Figure 1: Model geometry for the microchannel with electrodes and a reaction surface.

F L U I D  F L O W

Fluid flow in the channel follows the Navier-Stokes equations

ρ u∂
t∂

------- η∇2u ρu ∇⋅ u p∇+ +– F=

∇ u⋅ 0=
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where u denotes the velocity, ρ is the density, η is the dynamic viscosity, and p refers 
to the pressure. At steady state, the first time-dependent term disappears. The volume 
force F appearing in the equation is the electrothermal force fE given by

 (1)

where σ is the conductivity, ε = εrε0 equals the fluid’s permittivity, ω represents the 
electric field’s angular frequency, and τ = ε/σ gives the fluid’s charge-relaxation time. 
The field vector E contains the amplitude and orientation of the AC electric field but 
not its instantaneous value.

The following table gives the input data for the model:

As a result of Joule heating, ε and σ are temperature dependent. You can rewrite the 
gradients of theses entities using chain differentiation, which yields

 

and

where T is the fluid’s temperature. For water,

and 

Thus you can rewrite the electrothermal force (Equation 1) as

NAME VALUE DESCRIPTION

 ρ 1000 kg/m3 Density of water

 η 1.08·10-3 kg/(m·s) Dynamic viscosity of water

 σ 5.75·10-2 S/m Conductivity of water

 εr 80.2 Relative permittivity of water

 ω 2π·15·103 rad/s Angular frequency of the AC electric field

F fE=

fE 0.5 ∇σ
σ

-------- ∇ε
ε

-------+⎝ ⎠
⎛ ⎞ E εE

1 ωτ( )2
+

------------------------ 0.5 E 2∇ε+⋅–=

ε∇ ε T∂⁄∂( ) T∇=

σ∇ σ T∂⁄∂( ) T∇=

1 ε⁄( ) ε T∂⁄∂( ) 0.004 K 1–
–=

1 σ⁄( ) σ T∂⁄∂( ) 0.02 K 1–
=

A C  E L E C T R O K I N E T I C A L L Y  E N H A N C E D  S U R F A C E  R E A C T I O N S  |  3



ac_electrokinetic_2d.book  Page 4  Friday, November 2, 2007  9:20 AM
The following table contains the boundary conditions for the incompressible 
Navier-Stokes equations:

E L E C T R O S T A T I C S

Because the electrothermal force is a time-averaged entity, it is sufficient to solve the 
static electric field that corresponds to the root mean square (rms) value of the AC 
field. The rms value of the AC voltage is Vrms = 10 V.

To solve the electrostatics problem, turn to Laplace’s equation

 

with

 

and the constitutive equation

The boundary conditions for the electrostatic problem are as follows:

H E A T  TR A N S F E R

The power that a unit volume of fluid absorbs through Joule heating is

BOUNDARY CONDITION

Left Parabolic inflow with average velocity 0.1 mm/s and 
zero velocity at the upper and lower boundaries

Upper No slip condition

Lower No slip condition

Right Outflow with pressure p = 0

BOUNDARY CONDITION

Left electrode Electric potential, V = Vrms/2 = 5V

Right electrode Electric potential, V = -Vrms/2 = -5V

Other boundaries Electric insulation

fE 0.5ε 0.016 K 1–( ) T∇ E E

1 ωτ( )2
+

------------------------ 0.5 E 2 0.004 K 1–
–( )∇T+⋅⎝ ⎠

⎛ ⎞–=

∇– ε∇V( )⋅ 0=

E V∇–=

D ε0εrE=

Q σ E 2
=
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where E is the rms value of the electric field and σ is the fluid’s conductivity. The heat 
source, Q, appears in the stationary heat balance equation

where Cp denotes the heat capacity and k is the fluid’s thermal conductivity. This is the 
nonconservative formulation of the heat balance, which is consistent with the 
assumption of a divergence-free flow field.

The following table gives the relevant input data for the heat-transfer problem:

In general, the Navier-Stokes equations along with the convection and conduction 
equation form a coupled system that you should solve simultaneously.

This example assumes an ambient temperature T = 0 °C, and the electrodes are held 
steady at this temperature. The flow rate is small, and you can therefore assume that 
the temperature decreases symmetrically at the inlet and the outlet. The magnitude of 
the temperature gradient at both boundaries is such that the fluid reaches the ambient 
temperature at a distance of  1 mm from the boundary. At all other boundaries the 
model assumes that the channel is insulated.

C O N V E C T I O N  A N D  D I F F U S I O N  O F  T H E  A N A L Y T E

The material balance of the analyte comes from the equation

.

This equation gives the material balance in a nonconservative form because the flow 
field is divergence free. In this equation D denotes the diffusion coefficient and R 
represents the reaction rate. Here R equals zero because no reactions take place in the 
bulk of the fluid, only on the reaction surface.

The boundary conditions are as follows:

NAME VALUE DESCRIPTION

 ρ 1000 kg/m3 Density of water

 Cp 4.184·103 J/(kg·K) Heat capacity of water

 k 0.598 W/(m·K) Thermal conductivity of water

BOUNDARY CONDITION

Left The incoming flow has constant analyte concentration

Right Remaining concentration leaves the system through convection

∇ k∇T–( )⋅ Q ρCpu ∇T⋅–=

δts
c∂
t∂

----- ∇ D∇c–( )⋅+ R u ∇c⋅–=
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The following table gives the input data for the material balance:

B I N D I N G  R E A C T I O N

The reaction surface contains a total concentration Rt of antibody ligands. The portion 
of the bonded molecules is the concentration B. The binding rate depends on the 
analyte concentration on the surface, c, on the concentration of free antibodies, and 
on the association rate constant, kon. Similarly, bonded antibodies dissociate with a rate 
that depends on the concentration of the bonded ligands and on the dissociation rate 
constant, koff. Therefore, the equation that describes the material balance of adsorbed 
species (see Ref. 2) is:

 (2)

The reaction rate of the analyte on the surface equals the negative of the binding rate 
on the surface.

The table below gives the input data for the material balance of the adsorbed species:

The model assumes that the antibodies do not diffuse on the surface and that there is 
no leakage of the molecules at the edges of the surface.

Reaction surface Concentration consumed in the binding reaction as defined by 
Equation 2 (see next chapter)

Other boundaries Boundaries are insulated and the concentration gradients normal 
to these boundaries equal zero

NAME VALUE DESCRIPTION

 δts 1 Time-scaling coefficient

 D 1·10-11 m2/s Diffusivity of the analyte in the fluid

 R 0 M/s No reaction takes place within the fluid

 c0 1 nM = 1μmol/m3 Inlet analyte concentration

NAME VALUE DESCRIPTION

 kon 108 (M·s)-1 = 105 m3/(mol·s) Association rate constant

 koff 0.02 s-1 Dissociation rate constant

 Rt 1.67·10-11 M·m = 1.67·10-8 mol/m2 Total surface concentration 
of the antibody ligand

BOUNDARY CONDITION

B∂
t∂

------- konc Rt B–( ) koff B–=
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To study the effect of the applied electric field, you first run the model with Vrms = 0 V 
and then repeat the simulation for Vrms = 10 V.

S T E P - R E S P O N S E  A N A L Y S I S

Another interesting aspect to analyze is the system’s behavior when injecting a fixed 
amount of analyte over a limited time with a sudden cutoff in the analyte supply. To 
simulate such an experiment, use the analyte inlet concentration expression

 (3)

with t1 = 1000 s and c0 = 75 nM = 75 μmol/m3 (1 M ≡ 1 mol/l = 103 mol/m3). For 
this analysis, modify the material balance input data according to the following table 
to obtain a reaction-rate limited process.

Results and Discussion

Figure 2 shows the flow profile and concentration distribution without any applied 
electric field. In this case, the flow is laminar and has a parabolic profile. The effect of 
the reaction surface on the analyte concentration is visible only in the narrow region 
near the surface. Compare it to the flow and concentration with an applied electric field 
(Figure 3). Now the flow profile is far from parabolic: it has two distinct swirls and a 
narrow region with high flow velocity between the electrodes. Both of these figures 
represent the situation 5 s after the system introduces analyte at the left boundary.

Figure 4 depicts the flow and concentration just 1 s after introducing the analyte. It 
shows more clearly how the swirling patterns in the flow focus the analyte on a 
narrower path near the reaction surface. This flow results in a difference in the 
adsorption rate of the molecules with and without the electric field, (Figure 5). The 
average number of adsorbed molecules—the ratio between the total amount and the 
surface width—on the surface increases more rapidly with the electric field (the curve 
with squares) than without the electric field (the curve with triangles).

NAME VALUE DESCRIPTION

 kon 100 m3/(mol·s) Association rate constant

 koff 5·10-3 s-1 Dissociation rate constant

 Rt 1.67·10-11 mol/
m2

Total surface concentration of the antibody ligand

c t( )
c0

0⎩
⎨
⎧

=
t t1<

t t1>
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Figure 2: Microchannel flow and concentration at 5 s without any applied electric field.

Figure 3: Microchannel flow and concentration at 5 s with an applied electric field.
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Figure 4: Microchannel flow and concentration at 1 s with an applied electric field.

Figure 5: Binding of molecules on the reaction surface in the microchannel with (squares) 
and without (triangles) an applied electric field.
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Figure 6 shows the result for the average concentration of bonded molecules of the 
third and final simulation, in which you cut off the analyte supply at t = 1000 s. During 
the phase when the analyte supply is kept constant, the concentration of molecules on 
the binding surface approaches a constant maximum value near 10−11 mol/m2. When 
the supply at the inlet then stops, the concentration starts to decay. By varying the 
antibody ligand concentration and the association and dissociation rate constants, you 
can study the effects on the maximum concentration and the decay rate. Simulations 
of this kind can thus be useful for fitting a model to experimental data.

Figure 6: System response when the analyte supply at the inlet is cut off at t = 1000 s.

Modeling in COMSOL Multiphysics

This model solves the problem with two geometries and five application modes. 
Table 1 lists the geometries and their application modes.

The first geometry, named channel, is in 2D and represents the channel. Within this 
geometry the model uses four application modes: Electrostatics, Convection and 
Conduction, Incompressible Navier-Stokes, and Convection and Diffusion. The 
second geometry, named surface, is in 1D and simulates the reaction surface with the 
Diffusion application mode. The overall model couples this solution with the reaction 
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surface boundary condition of the Convection and Diffusion application mode on the 
first geometry. For this purpose you must define two extrusion-coupling variables.

You solve the model in three steps with different solvers in a progression using results 
from the previous step:

• First, solve the Electrostatics application mode with a stationary linear solver.

• Next, solve the Convection and Conduction and the Incompressible Navier-Stokes 
application modes together using a stationary nonlinear solver, because they form a 
coupled system through their subdomain settings.

• In the third step you use the time-dependent solver to solve the transport of the 
analyte. At this point the software solves two application modes simultaneously: 
Convection and Diffusion, and Diffusion.

COMSOL Multiphysics’ solver scripting capabilities allow you to record these solving 
stages, a feature which greatly facilitates repeated simulations.
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TABLE 1:  GEOMETRY AND APPLICATION MODE DESCRIPTION

GEOMETRY APPLICATION 
MODE

VARIABLES DESCRIPTION

channel Electrostatics V Solves the static electric potential in 
the channel

channel Convection and 
Conduction

T Solves the temperature distribution 
in the channel

channel Incompressible 
Navier-Stokes

u, v, p Solves the velocities in the x and y 
directions and the pressure 
distribution in the channel

channel Convection and 
Diffusion

c Solves the concentration of the 
analyte in the channel

surface Diffusion B Solves the concentration of the 
binded antibodies on the reaction 
surface
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Model Library path: MEMS_Module/Microfluidics_Models/
ac_electrokinetic_2d

Modeling Using the Graphical User Interface

M O D E L  L I B R A R Y

1 In the Model Navigator, click the New tab, then click the Multiphysics button.

2 Click the Add Geometry button.

3 Enter these settings in the dialog box:

4 Click OK.

5 Click the Add Geometry button once again and enter these settings:

Because the available unit systems give the wrong reference dimension for the 1D 
geometry, use the last setting to disable units for this geometry.

6 Click OK.

7 In the Multiphysics area, select the geometry channel (2D).

8 In the list of application modes, select MEMS Module>Electrostatics>Electrostatics, 
then click the Add button in the Multiphysics area.

9 Select the application mode COMSOL Multiphysics>Heat Transfer>Convection and 

Conduction, then click the Add button.

10 Select MEMS Module>Microfluidics>Incompressible Navier-Stokes, then click Add.

FIELD VALUE

Geometry name channel

Space dimension 2D

Independent variables x y z

FIELD VALUE

Geometry name surface

Space dimension 1D

Independent variables x y z

Unit system None
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11 Select MEMS Module>Microfluidics>Convection and Diffusion>Transient analysis, then 
click Add.

12 In the Multiphysics area, select the geometry surface (1D).

13 Select COMSOL Multiphysics>Convection and Diffusion>Diffusion>Transient analysis. In 
the Dependent variables edit field type B, then click Add.

14 Click OK.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu, choose Constants.

2 Define the following names, expressions, and (optionally) descriptions; when 
finished, click OK.

Later, you change the value of   the electric potential to 10 V and re-solve the model.

G E O M E T R Y  M O D E L I N G

First create the 2D geometry for the channel.

NAME EXPRESSION DESCRIPTION

epsilon0 8.854188e-12[F/m] Permittivity of free space

epsilonr_f 80.2 Relative permittivity, fluid

epsilon_f epsilonr_f*epsilon0 Permittivity, fluid

k_f 0.598[W/(m*K)] Thermal conductivity, fluid

rho_f 1000[kg/m^3] Density, fluid

Cp_f 4.184[kJ/(kg*K)] Heat capacity, fluid

eta_f 1.08e-3[Pa*s] Dynamic viscosity, fluid

sigma_f 5.75e-2[S/m] Electric conductivity, fluid

tau epsilon_f/sigma_f Charge relaxation time, fluid

D_a 1e-11[m^2/s] Diffusion coefficient, analyte

omega 2*pi[rad]*15[kHz] Angular frequency, AC electric field

V_rms 0[V] Electric potential, RMS value

T_amb 0[degC] Ambient temperature

u_av 0.1[mm/s] Average flow velocity at the inlet

c0 1[umol/m^3] Analyte concentration at the inlet

k_on 1e5[m^3/(mol*s)] Association rate constant

k_off 0.02[1/s] Dissociation constant

R_t 1.67e-8[mol/m^2] Total surface concentration, antibody 
ligand
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1 Click the channel tab in the drawing area.

2 From the Options menu, choose Axes/Grid Settings.

3 In the dialog box, click the Axis tab, select the Axes equal check box, and enter these 
settings:

4 Click the Grid tab.

5 Clear the Auto check box and make these settings:

6 Click OK.

7 Click the Rectangle/Square button on the Draw toolbar and draw a rectangle with 
diagonally opposite corners at (0, 0) and (2.5·10−4, 4·10−5).

8 Draw the following points by successively using the Point tool in the Draw toolbar.

SETTING VALUE

x min -5e-5

x max 30e-5

y min -5e-5

y max 10e-5

SETTING VALUE

x spacing 1e-5

y spacing 1e-5

NAME  x  y  

PT1 0.5e-4 0

PT2 1.1e-4 0

PT3 1.3e-4 0

PT4 1.9e-4 0

PT5 0.9e-4 0.4e-4

PT6 1.1e-4 0.4e-4
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The completed 2D geometry should look like that in the following picture:

The completed 2D geometry for a microchannel detector.

Next create the 1D geometry for the reaction surface.

1 Click the surface tab.

2 From the Options menu, choose Axes/Grid Settings.

3 In the dialog box, click the Axis tab, then enter these settings:

4 Click the Grid tab. Clear the Auto check box. In the x spacing edit field type 1e-5, 
then click OK.

5 On the Draw toolbar select the Line tool and draw a line from 0.9·10−4 to 1.1·10−4.

The geometry is now complete. 

SETTING VALUE

x min -5e-5

x max 30e-5
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P H Y S I C S  S E T T I N G S

Expressions and Coupling Variables
Follow these steps to create the expressions for computing the electrothermal force, to 
define the expressions and coupling variables needed to solve the binding reaction, and 
provide the integration-coupling variables needed for postprocessing.

Note: You create expressions separately for the two geometries.

Start by defining scalar expressions for the electrothermal force components.

1 Click the channel tab to select that geometry.

2 From the Options menu, choose Expressions>Scalar Expressions.

3 In the dialog box, enter the expressions in the following table for the x- and y- 
components of the electrothermal force. Note that this example uses the expressions 
tmp1 and tmp2 only to simplify the writing of Fx_et and Fy_et.

4 Click OK.

Next set the expressions and extrusion-coupling variables you need to solve the surface 
reaction.

1 From the Options menu, choose Expressions>Boundary Expressions.

2 In the Boundary selection list, select Boundary 5.

3 Create the following boundary expression (c_surf is an extrusion coupling variable 
that you define later):

COMSOL Multiphysics marks the unit of react_bulk as inconsistent because of 
the coupling variable. You can disregard this warning.

4 Click OK. 

NAME EXPRESSION

tmp1 (Tx*Ex_emes+Ty*Ey_emes)/(1+(omega*tau)^2)

tmp2 normE_emes^2

Fx_et -0.5*epsilon_f*(0.016[1/K]*tmp1*Ex_emes-0.5*0.004[1/K]*tmp2*Tx)

Fy_et -0.5*epsilon_f*(0.016[1/K]*tmp1*Ey_emes-0.5*0.004[1/K]*tmp2*Ty)

NAME EXPRESSION

react_bulk k_off*c_surf-k_on*c*(R_t-c_surf)
A C  E L E C T R O K I N E T I C A L L Y  E N H A N C E D  S U R F A C E  R E A C T I O N S  |  16



ac_electrokinetic_2d.book  Page 17  Friday, November 2, 2007  9:20 AM
5 Click the surface tab to select that geometry.

6 From the Options menu, choose Expressions>Subdomain Expressions.

7 In the Subdomain selection list, select Subdomain 1. 

8 Define the following subdomain expression (the term c_bulk is an 
extrusion-coupling variable that you define next); when done, click OK.

9 Click the channel tab to select that geometry.

10 From the Options menu, choose Extrusion Coupling Variables>Boundary Variables.

11 Select Boundary 5. In the first row of the Name column type c_bulk, then type c in 
the corresponding Expression column.

12 Click the General transformation option button.

Configuring the source of the extrusion coupling variable for the channel geometry.

13 Click the Destination tab.

14 From the Geometry list select surface, and from the Level list select Subdomain.

NAME EXPRESSION

react_surf k_on*c_bulk*(R_t-B)-k_off*B
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15 In the Subdomain selection list, click the check box to select Subdomain 1. Make sure 
the Use selected subdomains as destination check box is selected.

Configuring the destination of the extrusion coupling variable for the channel geometry.

16 Click OK.

17 Verify that you still have the surface tab selected; if it is not selected, click it.

18 From the Options menu, choose Extrusion Coupling Variables>Subdomain Variables.

19 From the Subdomain selection list select 1, go to the first row in the Name column 
and enter c_surf, then type B in the corresponding Expression column.

20 Click the General transformation option button.

Configuring the source of the extrusion coupling variable for the surface geometry.

21 Click the Destination tab.
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22 From the Geometry list select channel, and from the Level list select Boundary.

23 In the Boundary selection list, click the check box to select Boundary 5. Make sure 
the Use selected boundaries as destination check box is selected.

Configuring the destination of the extrusion coupling variable for the surface geometry.

24 Click OK.

Finally set the integration-coupling variables needed for postprocessing. They 
represent the total amount of bonded molecules on the reaction surface and its length, 
respectively. Their ratio thus gives the average concentration of bonded molecules at 
the surface.

1 Select the surface geometry.

2 From the Options menu, select Integration Coupling Variables>Subdomain Variables.

3 Select Subdomain 1 and enter these settings:

4 Click OK.

Subdomain Settings
1 From the Multiphysics menu, select 1 channel: Electrostatics (emes).

2 From the Physics menu, select Subdomain Settings.

3 Select Subdomain 1.

NAME EXPRESSION INTEGRATION 
ORDER

GLOBAL 
DESTINATION

B_total B 4 Selected

x_length 1 4 Selected
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4 Under the options for the Constitutive relation click the option button 
corresponding to D = ε0εrE.

5 In the Relative permittivity edit field type epsilonr_f, then click OK.

6 From the Multiphysics menu, select 2 channel: Convection and Conduction (cc).

7 From the Physics menu, select Subdomain Settings.

8 Select Subdomain 1, then enter settings as in this table; when finished, click OK.

9 From the Multiphysics menu, select 3 channel: Incompressible Navier-Stokes (mmglf).

10 From the Physics menu, select Subdomain Settings.

11 In the dialog box select Subdomain 1, then enter these settings:

12 Click the Init tab. In the x-velocity edit field, type u_av. Click OK.

13 From the Multiphysics menu, select 4 channel: Convection and Diffusion (chcd).

14 From the Physics menu, select Subdomain Settings.

15 Select Subdomain 1, then enter settings as in the following table; for the Time-scaling 

coefficient and the Reaction rate, leave the default settings. When finished, click OK.

QUANTITY VALUE/EXPRESSION DESCRIPTION

 k (isotropic) k_f Thermal conductivity

 ρ rho_f Density

 Cp Cp_f Heat capacity at constant 
pressure

 Q sigma_f*normE_emes^2 Heat source

 u u x-velocity

 v v y-velocity

QUANTITY VALUE/EXPRESSION DESCRIPTION

 ρ rho_f Density

 η eta_f Dynamic viscosity

 Fx Fx_et Volume force, x dir.

 Fy Fy_et Volume force, x dir.

QUANTITY VALUE/EXPRESSION DESCRIPTION

 D (isotropic) D_a Diffusion coefficient

 u u x-velocity

 v v y-velocity
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16 From the Multiphysics menu, choose 5 surface: Diffusion (di).

17 From the Physics menu, select Subdomain Settings.

18 Select Subdomain 1, then enter these settings; when finished, click OK.

Boundary Conditions
1 From the Multiphysics menu, choose 1 channel: Electrostatics (emes).

2 From the Physics menu, select Boundary Settings.

3 Enter boundary settings from the following table; when finished, click OK.

4 From the Multiphysics menu, choose 2 channel: Convection and Conduction (cc).

5 From the Physics menu, select Boundary Settings.

6 Enter boundary settings from the following table; when finished, click OK.

The default boundary condition (thermal insulation) applies to the boundaries not 
listed in the table.

7 From the Multiphysics menu, select 3 channel: Incompressible Navier-Stokes (mmglf).

8 From the Physics menu, select Boundary Settings.

9 Enter boundary settings from the following table; when finished, click OK.

QUANTITY VALUE/EXPRESSION DESCRIPTION

 D 0 Diffusion coefficient

 R react_surf Reaction rate

SETTINGS BOUNDARY 4 BOUNDARY 8 BOUNDARIES 1–3, 
5–7, 9, 10

Boundary 
condition

Electric potential Electric potential Zero charge/
Symmetry

V0 V_rms/2 -V_rms/2

SETTINGS BOUNDARIES 1, 10 BOUNDARIES 4, 8

Boundary condition Heat flux Temperature

q0 -k_f*(T-T_amb)/1[mm]- 
nx*u*rho_f*Cp_f*T

T0 T_amb

SETTINGS BOUNDARY 1 BOUNDARY 10 BOUNDARIES 2–9

Boundary type Inlet Outlet Wall

Boundary condition Laminar inflow Pressure, no 
viscous stress

No slip
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10 From the Multiphysics menu, select 4 channel: Convection and Diffusion (chcd).

11 From the Physics menu, select Boundary Settings.

12 Enter boundary settings from the following table; when finished, click OK.

13 From the Multiphysics menu, select 5 surface: Diffusion (di).

14 From the Physics menu, select Boundary Settings.

15 Verify that the Boundary condition is set to Insulation/Symmetry on both boundaries.

16 Click OK.

M E S H  G E N E R A T I O N

1 Select the channel geometry.

2 From the Mesh menu, select Free Mesh Parameters.

3 Click the Boundary tab.

4 Select Boundaries 4, 5, and 8.

5 In the Maximum element size edit field type 0.2e-6.

6 Click the Remesh button to initialize the mesh for the channel geometry. Click OK.

7 Select the surface geometry.

8 Click the Initialize Mesh button on the Main toolbar to initialize the mesh for the 
surface geometry.

C O M P U T I N G  T H E  S O L U T I O N

You solve the model in three steps using three different solvers.

1 Click the Solver Manager button on the Main toolbar to launch the Solver Manager.

U0 u_av

Lentr 1e-4

Constrain end points to zero Yes

p0 0

SETTINGS BOUNDARY 1 BOUNDARY 5 BOUNDARY 10 BOUNDARIES 2–4, 6–9

Boundary 
condition

Concentration Flux Convective 
flux

Insulation/ 
Symmetry

c0 c0

N0 react_bulk

SETTINGS BOUNDARY 1 BOUNDARY 10 BOUNDARIES 2–9
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2 On the Script page, select the Automatically add commands when solving check box. 
With this setting, COMSOL Multiphysics records the subsequent solver commands 
so that you can reuse them when you later solve the model for Vrms = 10 V.

3 On the Solve For page, select channel (2D)>Electrostatics (emes).

4 Click Solve.

5 Click the Initial Value tab. In the Values of variables not solved for and linearization 

point area, select the Current solution option button.

6 Return to the Solve For page. Select the application modes channel (2D)>Convection 

and Conduction (cc) and channel (2D)>Incompressible Navier-Stokes (mmglf).

7 Click Solve.

8 Click the Solver Parameters button on the Main toolbar to launch the Solver 

Parameters dialog box.

9 From the Solver list, select Time dependent.

10 On the General page, type 0:0.1:5 in the Times edit field in the Time stepping area.

11 Click OK to close the Solver Parameters dialog box.

12 Return to the Solver Manager.

13 On the Solve For page, select the application modes 
channel (2D)>Convection and Diffusion (chcd) and surface (1D)>Diffusion (di).

14 Click OK to close the Solver Manager dialog box.

15 Click Solve button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

Begin by visualizing the fluid flow and the analyte concentration in the flow channel 
after 5 s.

1 In the drawing area, select the channel geometry.

2 Click the Plot Parameters button on the Main toolbar.

3 On the General page of the Plot Parameters dialog box, select the check boxes for 
Surface, Arrow, Streamline, and Geometry edges. Make sure the Solution at time list is 
initialized to 5.

4 Click the Surface tab. From the Predefined quantities list, select Convection and 

Diffusion (chcd)>Concentration, c. In the Unit edit field, type umol/m^3.

5 Click the Arrow tab. In the Plot arrows on list select Subdomains. 

6 Click the Subdomain Data tab. From the Predefined quantities list, select 
Incompressible Navier-Stokes (mmglf)>Velocity field.
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7 In the Arrow parameters area, find the Arrow length list and select Proportional.

8 Click the Color button. Select black, then click OK to close the Arrow Color dialog 
box.

9 Go to the Streamline page. Click the Streamline Data tab, then in the Predefined 

quantities list select Incompressible Navier-Stokes (mmglf)>Velocity field.

10 From the Streamline plot type list, select Magnitude controlled.

11 Click the Line Color tab. Select the Uniform color option button. Click the Color 
button, then select the orange color corresponding to the RGB values (255, 102, 
0). To do so, click the RGB tab and enter the values directly. Click OK to close the 
Streamline Color dialog box.

12 Return to the General page. From the Plot in list, select New figure.

13 Click OK to generate the plot in Figure 2 on page 8.

Next, generate the first graph in Figure 5 on page 9 with the following steps:

1 Select the surface geometry.

2 From the Postprocessing menu, select Cross-Section Plot Parameters.

3 On the General page, verify that all solutions in the Solutions to use list are selected. 
From the Plot in list, select New figure.

4 Click the Point tab. In the y-axis data area, type B_total/x_length in the 
Expression edit field. In the Coordinates area, type 1e-4 in the x edit field.

5 Click the Line Settings button. From the Line marker list select Triangle, then click OK 
to close the Line Settings dialog box.

6 Click OK.

Leave the figure windows open to enable comparison with the solutions for the case 
where an electric field has been applied.

Re-Solve the Model with an Applied Electric Field

In this second part of the modeling session, you apply an external electric field.

O P T I O N S  A N D  S E T T I N G S

Choose Options>Constants. Change the Expression for V_rms to 10[V], then click OK.

C O M P U T I N G  T H E  S O L U T I O N

1 Click the Solver Manager button on the Main toolbar.
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2 On the Script page, select Solve using a script check box. The following solver script 
appears in the script area (the orders between the entries in the solcomp and 
outcomp lists can vary):

3 Click OK to close the Solver Manager.

4 Click the Solve button on the Main toolbar. The software automatically repeats all 
the solving stages you recorded in the first part of this model to compute the 
solution for Vrms = 10 V.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 In the drawing area, select the channel geometry.

2 Click the Plot Parameters button on the Main toolbar.

3 On the General page, select New figure from the Plot in list. Click Apply.

The plot displayed in Figure 3 on page 8—visualizing the fluid flow and the analyte 
concentration in the flow channel after 5 s in the presence of an electric field —
should now appear in the Figure 3 window. To plot the same quantities at  t = 1 s, 
proceed with the following steps:

4 Still on the General page, from the Solution at time list select 1.

5 From the Plot in list select New figure, then click OK.
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The new figure window now contains a plot resembling that in Figure 4. This is the 
plot you see in the Model Navigator if you open the model from the Model Library.

Finally, finish reproducing Figure 5, which illustrates the binding rate of the analyte, 
by executing the following instructions:

1 Select the surface geometry.

2 From the Postprocessing menu, select Cross-Section Plot Parameters.

3 On the Point page, click the Line Settings button. From the Line marker list select 
Square, then click OK to close the Line Settings dialog box.

4 Click the General tab.

5 Select the Keep current plot check box.

6 Click the Title/Axis button.

7 Activate the Title edit field, then enter the title Average concentration of 
bonded molecules [mol/m<sup>2</sup>].

The HTML tags produce a superscript figure “2” for the exponent.

8 Click OK to close the Title/Axis Settings dialog box.

9 Click OK to generate the plot.

The two graphs in the Figure 2 window should now look like those in Figure 5.

To study an animation of the solution, click the Animate button on the Plot toolbar.

Step-Response Simulation

O P T I O N S  A N D  S E T T I N G S

From the Physics menu, select Constants. Edit the expressions for the four last constants 
according to the following table; when done, click OK.

P H Y S I C S  S E T T I N G S

1 From the Multiphysics menu, select 4 channel: Convection and Diffusion (chcd).

2 From the Physics menu, select Boundary Settings. Select Boundary 1.

NAME EXPRESSION

c0 75[umol/m^3]

k_on 100[m^3/(mol*s)]

k_off 5e-3[1/s]

R_t 1.67e-11[mol/m^2]
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3 Change the entry in the c0 edit field to c0*(t<1000[s]), then click OK.

The logical expression implements the step function in Equation 3.

C O M P U T I N G  T H E  S O L U T I O N

1 Click the Solver Parameters button on the Main toolbar.

2 Change the entry in the Times edit field to 0:25:950 975:1025 1050:50:2000.

3 Set the Relative tolerance to 1e-4 and the Absolute tolerance to 1e-3.

4 Click the Time Stepping tab.

5 From the Time steps taken by solver list, select Intermediate.

6 Click OK to close the Solver Parameters dialog box.

7 Click the Solver Manager button on the Main toolbar.

8 On the Script page, click the Add Current Solver Settings button.

A femtime command with the current solver settings appears in the script area.

9 Because this command should replace the previous one, cut out the complete upper 
femtime command together with the asseminit command line immediately 
before it as well as the fem0=xfem; line immediately after it. When you are done, 
the contents of the script area should be as in the following figure (again, the entries 
in the solcomp and outcomp lists can be ordered differently).
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10 Click OK to close the Solver Manager.

11 Click the Solve button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To reproduce the plot in Figure 6, follow these steps:

1 Select the surface geometry.

2 From the Postprocessing menu, select Cross-Section Plot Parameters.

3 On the General page, select New figure from the Plot in list.

4 On the Point page, click the Line Settings button. From the Line marker list select 
None, then click OK to close the Line Settings dialog box.

5 Click OK to close the Cross-Section Plot Parameters dialog box and generate the plot.
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