
 
Microfluidics : Microchannel Cell 

Microchannel Cell 
This example was originally formulated by Albert Witarsa under Professor Bruce Finlayson’s 
supervision at the University of Washington in Seattle. It was part of a graduate course in 
which the assignment consisted of using mathematical modeling to evaluate the potential of 
patents in the field of microfluidics. 

This model treats a so-called H-micro cell for separation through diffusion. The cell puts two 
different laminar streams in contact for a controlled period of time. The contact surface is 
well defined, and by controlling the flow rate it is possible to control the amount of species 
transported from one stream to the other through diffusion.

Figure 6-15: Diagram of the H-micro cell. 

Model Definition 
The geometry of the microcell (Figure 6-16) is taken from Albert Witarsa’s and Professor 
Finlayson’s assignment. The cell geometry is divided in half due to symmetry. The design is 
done to avoid upsets in the flow field when the two streams, A and B, are united. The reason 
for this is to avoid the two streams mixing through convection, because this would mix all 
species equally and you would lose control over the separation abilities. The transport of 
species from streams A to B should take place only by diffusion, which implies that species 
with low diffusion coefficients stay in their respective streams.

Figure 6-16: Model geometry. Due to symmetry, only half the cell must be modeled. The design is also required so 
as to smoothly let both streams come in contact with each other. This avoids any type of convective mixing. 
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The first part of the problem involves the solution of the fluid flow in the H-cell. According to 
the specifications, the flow rate at the inlet is roughly 0.1 mm/s. This implies that the 
Reynolds number is low and well inside the region of laminar flow: 

(6-23)  

Equation 6-23 gives a Reynolds number of 0.001 for a water solution and the channel 
dimensions given in Figure 6-16, and this value is typical for microchannels. Thus it is easy to 
get a numerical solution of the full momentum balance and continuity equations for 
incompressible flow with a reasonable number of elements. The equations that you must 
solve are the Navier-Stokes equations at steady-state: 

(6-24)  

where ρ denotes density (kg/m
3
), u is the velocity vector (m/s), η denotes viscosity 

(kg/m·s), and p equals pressure (Pa).  

Separation in the H-cell involves species in a relatively low concentration compared to the 
solvent, in this case water. This means that the solute molecules interact only with water 
molecules, and it is safe to use Fick’s law to describe the diffusive transport in the cell. The 
mass balance equation for a solute is present in the Convection-Diffusion application mode, 
which solves the equation 

(6-25) . 

In this equation, D denotes the diffusion coefficient (m
2
/s) and c represents the 

concentration (mol/m
3
). This model uses three different values of D in order to simulate the 

mixing of different species. The values of the diffusion coefficient are ,  and 
. 

In the first approach, assume that a change in solute concentration does not influence the 
fluid’s density and viscosity. This implies that it is possible to solve the Navier-Stokes 
equations first and then solve the mass balance equation. In order to solve these equations, 
you need some boundary conditions. A second step uses a quadratic dependence of the 
viscosity on concentration: 

(6-26) . 

The influence of concentration on viscosity is usually observed in solutions of larger 
molecules. 

Start by looking at the boundary conditions for the Navier-Stokes equations, conditions that 
Figure 6-17 explains qualitatively.

Figure 6-17: Boundary conditions for Navier-Stokes equations. 

The normal flow/pressure conditions and the inlets and outlets set the velocity at the 
boundary perpendicular to the boundary. This is expressed by 
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(6-27)  

where pi is the pressure. At the outlet, the pressure is set to zero, and at the inlet the 

pressure is given by the pressure drop over the cell. The inlet and outlet conditions comply 
with the H-cell being a part of a channel system of constant width, which allows for the 
assumption of developed flow, and that velocity components tangential to the outlet 
boundary are zero. The symmetry boundary condition means that the velocity component in 
the normal direction of the surface is zero: 

(6-28) . 

The no-slip conditions state that the velocity is zero in the x-, y- and z-directions at the wall: 

(6-29)  

The boundary conditions for the mass balance define the composition of the solution at the 
inlet: 

(6-30)  

The walls of the cell are modeled as insulating boundaries, which yields 

(6-31)  

This equation states that the flux perpendicular to the boundary equals zero. The outlet 
condition is obtained assuming that the convective transport is much larger than the diffusive 
transport perpendicular to the outlet. This is given in the equation 

(6-32)  

which eliminates concentration gradients in the direction of flow at the position of the outlet. 

Results 
Figure 6-18 shows the velocity field, defined as the modulus of the velocity vector. The flow 
is symmetric and is not influenced by the concentration field.

Figure 6-18: Modulus of the velocity vector. 

Figure 6-19 shows the concentration distribution for a species with a relatively large 
diffusivity, the light species in this study.
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Figure 6-19: Concentration distribution for the species with the larger diffusivity. 

The calculations show that the degree of mixing is almost perfect for the lighter species. The 
species with a diffusion coefficient that is ten times less than the lighter species shows a 
completely different result.

Figure 6-20: Concentration distribution for species with the smaller diffusivity. 

The concentration distribution in Figure 6-20 indicates that the diffusion coefficient for the 
species is low enough to avoid any significant mixing between streams A and B. The 
simulation clearly shows that the H-cell can separate lighter molecules from heavier ones. A 
cascade of H-cells can achieve a very high degree of separation. 

In some cases, especially those involving solutions of macro-molecules, the concentration of 
the macro-molecule has a large influence on the liquid’s viscosity. In such a case it is 
necessary to solve the Navier-Stokes and convection-diffusion equations simultaneously. 
Figure 6-21 shows the results of this simulation. You can see the flow field is largely 
influenced by changes in the concentration. It is clear from this plot that the velocity 
becomes asymmetric due to changes in viscosity.
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Figure 6-21: Velocity field. The viscosity varies with the concentration according to η = η0(1 + c2). The figure shows 

that the velocity field is greatly affected by variations in concentration. Compare it to the velocity field in Figure 6-18. 

Model Library Path: Chemical_Engineering_Module/Microfluidics/hcell 

Modeling Using the Graphical User Interface 

OPTIONS AND SETTINGS 

GEOMETRY MODELING 

1 Start COMSOL Multiphysics. 

2 On the New page set the Space dimension to 3D 

3 In the list of application modes select 
Chemical Engineering Module>Momentum balance>Incompressible Navier-
Stokes. 

4 Click the Multiphysics button, then click Add. 

5 In the list of application modes select 
Chemical Engineering Module>Mass balance>Convection and Diffusion. 

6 Click OK. 

1 Select Constants from the Options menu. 

2 Enter the following variable names and expressions in the Constants dialog box; when 
done, click OK: 

NAME EXPRESSION 

eta 1e-3 

rho 1e3 

p0 2 

D 1e-11 

c0 1 

1 From the Draw menu select Work Plane Settings. 

2 Use the default Quick work plane (the x-y plane at z = 0) by clicking OK. 
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You have now created half of the 2D cross section and can use copy, paste, and rotate 
operations to create the other half. 

PHYSICS SETTINGS 

3 Open the Axes/Grid settings from the Options menu. 

4 On the Axis page enter the following settings: 

PROPERTY VALUE 

x min -1 

x max 15 

y min -7 

y max 7 

5 On the Grid page clear the Auto check box and set both the x spacing and y spacing to 
1. 

6 Click the Line button on the Draw toolbar, then click the points with the x- and y-
coordinates at (0, 6) and (0, 2). 

7 Select the 2nd Degree Bezier Curve tool on the Draw toolbar and click at the coordinate
pairs (0, 0) and (2, 0). 

8 Select the Line tool and click at the coordinates (12, 0). 

9 Select the 2nd Degree Bezier Curve tool and click at the coordinates (14, 0) and  
(14, 2). 

10 Select the Line tool and click at the coordinates (14, 6). Continue by clicking at the 
coordinates (13, 6) and (13, 2). 

11 Select the 2nd Degree Bezier Curve tool and click at the coordinates (13, 1) and (12, 
1). 

12 Select the Line tool and click at the coordinates (2, 1). 

13 Select the 2nd Degree Bezier Curve tool and click at the coordinates (1, 1) and (1, 2). 

14 Select the Line tool and click at the coordinates (1, 6). 

15 Click the right mouse button to close the set of lines and create a solid object. 

1 Click the Copy button and then the Paste button, both on the Main toolbar. Let the 
Displacements remain at 0 and click OK. 

2 Click the Rotate button on the Draw toolbar and enter 180 in the Rotation angle edit 
field. 

3 Set the point (7,0) as the Center point. Click OK. 

4 Choose Select All in the Edit menu. 

5 Click the Create Composite Object button on the Draw toolbar. 

6 Clear the Keep interior boundaries check box. Click OK. 

7 Select Extrude from the Draw menu. Let the Distance remain 1. Click OK. 

8 Click the Scale button on the Draw toolbar. 

9 Enter 1e-5 in both Scale factor edit fields.  

10 Click OK. 

The cross section is now finished and you can extrude it to the full 3D geometry. 

The last step is to scale the geometry to the correct scale. 
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Boundary Conditions 

Subdomain Settings 

MESH GENERATION 

1 Select Geom1: Incompressible Navier-Stokes (chns) from the Multiphysics menu. 

2 Select Boundary Settings from the Physics menu. 

3 Specify boundary conditions as in the following table; when done, click OK: 

BOUNDARY 2, 8 20, 22 4 ALL 
OTHER 

Type Normal flow/ 
Pressure 

Normal flow/ 
Pressure 

Slip/ 
Symmetry 

No-slip 

p p0 0 - - 

4 Select Geom1: Convection and Diffusion (chcd) from the Multiphysics menu. 

5 Select Boundary Settings from the Physics menu. 

6 Specify the boundary conditions in the following table; when done, click OK: 

BOUNDARY 2 8 20, 22 ALL OTHER 

Type Concentration Concentration Convective 
flux 

Insulation/ 
symmetry 

c0
 c0 0 - - 

1 Select Geom1: Incompressible Navier-Stokes (chns) from the Multiphysics menu. 

2 Select Subdomain Settings from the Physics menu. 

3 Specify the subdomain settings in this table; when done, click OK: 

SUBDOMAIN 1 

ρ rho 

η eta 

Fx 0 

Fy 0 

4 Select Geom1: Convection and Diffusion (chcd) from the Multiphysics menu. 

5 Select Subdomain Settings from the Physics menu. 

6 Specify the subdomain settings given below; when done, click OK: 

SUBDOMAIN 1 

D isotropic D 

R 0 

u u 

v v 

w w 
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COMPUTING THE SOLUTION 
Start by first computing the solution for the velocity field and then use that solution for 
solving the mass transport problem. 

You have now computed the velocity field and can use that solution to make a parametric 
analysis for the mass transport problem with varying diffusivity. 

POSTPROCESSING AND VISUALIZATION 
To create Figure 6-18 follow these steps: 

To create Figure 6-19 follow these steps: 

1 Select Free Mesh Parameters from the Mesh menu. 

2 Select Finer from the Predefined mesh sizes list. 

3 Click the Remesh button and then click OK. 

1 Click the Solver Manager button on the Main toolbar. 

2 On the Solve For page select Incompressible Navier-Stokes (chns). 

3 Click the Initial value tab and click the Initial value expression option button. 

4 Click OK. 

5 Click the Solve button on the Main toolbar. 

1 Click the Solver Manager button on the Main toolbar. 

2 On the Solve For page select Convection and Diffusion (chcd). 

3 Click the Initial Value tab and then click the Current solution option button. 

4 Click OK. 

5 Open the Solver Parameters dialog box from the Solve menu. Select Parametric from 
the Solver list. 

6 Enter D in the Name of parameter edit field. 

7 Edit 1e-10 5e-11 1e-11 in the List of parameter values edit field. 

8 Click OK. 

9 Click the Solve button on the Main toolbar. 

1 Open the Plot Parameters dialog box from the Postprocessing menu. 

2 Select the Slice check box on the General page. 

3 Clear the Element refinement Auto check box and enter 5 in the corresponding edit 
field. 

4 Click the Slice tab. 

5 Set Slice data to Velocity field (chns) in the Predefined quantities list. 

6 Under Slice positioning set x levels to 5, y levels to 2, and z levels to 1. 

7 Click OK. 

1 Open the Plot Parameters dialog box from the Postprocessing menu. 

2 On the General page select 1e-10 from the Parameter value list. 

3 Go to the Slice page and select Concentration, c from the Predefined quantities list. 
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Figure 6-20 is create the same way as Figure 6-19 except using the parameter value  
1e-11. 

PHYSICS SETTINGS—STUDY 2 

COMPUTING THE SOLUTION—STUDY 2 
When the viscosity is concentration dependent you must solve for all equations 
simultaneously. 

POSTPROCESSING AND VISUALIZATION—STUDY 2 
To create Figure 6-21, do exactly as for Figure 6-18. 

4 Click OK. 

1 Select 1 Incompressible Navier-Stokes (chns) from the Multiphysics menu. 

2 Open the Subdomain Settings dialog box and change the viscosity expression from eta 
to eta*(1+c^2). 

3 Click OK. 

1 Click the Solver Manager button on the Main toolbar. 

2 In the Solve page select Geom1 (3D) from the Solve for variables list. Click OK. 

3 Open the Solver Parameters dialog box from the Solve menu. 

4 Select Stationary nonlinear from the Solver list. Click OK. 

5 Click the Solve button on the Main toolbar. 
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